Page 3 of 19

XBCD 0.2.7 Discussion

Posted: Sat Apr 02, 2011 4:12 pm
by Squall Leonhart
no worries

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 6:45 am
by IncrediClint
after rebooting FFB stopped working on my speedster 3. Tried reinstalling 0.2.7 but it didn't help.

 


All games still show the option to turn it on or off, but nothing happens either way. Dxdiag shows that the wheel is using the xbcdr.dll FFB driver as well.

 


Any ideas what could be the problem?

 


Windows 7 x64 btw.

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 8:22 am
by Squall Leonhart
do you have the Visual C 2010 SP1 runtime installed?

 


both dll's are built against 2010 so you need both the x86 and x64 redistributables installed

 


Visual C++ 2010 Redistributable SP1 (x86)


Visual C++ 2010 Redistributable SP1 (x64)

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 8:35 am
by IncrediClint
yup, both installed.

 


I just tried another full uninstall/install. Before doing so I removed all registry entries for xbcd and removed all xbcd files found on my system, hidden files etc..

 


Still running in test mode, I rebooted, installed XBCD 0.2.7, signed "c:\windows\system32\drivers\xbcd.sys", and rebooted again. Then went to device manager to update the controller and I get a window saying:

 


"Windows encountered a problem installing the driver software for your device."

 


"Windows found driver software for your device but encountered an error while attempting to install it."

 


XBCD Xbox Steering Wheel

 


"There is no driver selected for the device information set or element."

 


No idea what's going on. I -may- have installed xbcd 1.07 at some point in the past and xbcd 0.2.7 might have been installed on top of 1.07...

 


0.2.7 is completely self contained though right? No need for anything else?

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 8:39 am
by Squall Leonhart
if 1.07 was installed previously, it can bork the setup, i've had people getting issues trying to overwrite 1.7's rumble dll.

 


in device manager, right click the controller, uninstall with delete drivers selected


uninstall xbcd 2.x and reinstall 1.7, then remove that.

 


reboot and reinstall the latest xbcd then reconnect your controller.

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 9:03 am
by IncrediClint
Same thing again. BTW, it shows up as 'Unknown Device" in device manager, no MS common controller class at all.

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 9:06 am
by Squall Leonhart
try installing the driver files copied to the xbcd\driver folder, sometimes the pnf file helps.

 


OH, also use the command console with elevation and use pnputil (pnputil -e to check, pnputil -d [inf name] to delete) to check for currently installed versions of the xbcd driver, sometimes the driver cache isn't updated properly and it screws the install up.

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 9:24 am
by IncrediClint
Still the same.

 


pnputil -e shows:

 


oem36.inf


XBCD Project


Human Interface Devices


16/05/2008 1.1.0

 


oem37.inf


XBCD Project


Human Interface Devices


16/05/2008 1.1.0

 


oem38.inf


XBCD Project


Human Interface Devices


16/05/2008 1.1.0

 


oem39.inf


Redcl0ud


Human Interface Devices


5/13/2005 1.0.7

 


I'm assuming oem39.inf needs to be gone?

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 9:28 am
by Squall Leonhart
get rid of them all, they could all be blocking the install.

XBCD 0.2.7 Discussion

Posted: Sun Apr 03, 2011 9:45 am
by IncrediClint
That fixed it, installed and working.. except for the force feedback/vibration.

 


Which is odd... after you added speedster 3 I downloaded 0.2.7 again and reinstalled it over top of the existing 0.2.7 and FFB started working.

 


FFB works in the setup utility test sliders, and it can be toggled off/on in games ( not greyed out as it is when there is no FFB support for the wheel), it just doesn't do anything.

 


Live For Speed reports "CreateEffect Failed" "Could not setup FF steer device".

 


iRacing doesn't do anything either.

 


Edit: Nm, got FFB working. Had to change from 'Virtual Hid Device' to '6 axis 10 button device' in the Game Controllers dialog. [img]<fileStore.core_Emoticons>/emoticons/smile.png[/img]/emoticons/smile@2x.png 2x" width="20" height="20" />