Page 19 of 19

XBCD 0.2.7 Discussion

Posted: Mon Feb 25, 2013 9:25 pm
by Ashnal
Well then, any suggestions how I might be able to separate the triggers using some other method?

 


... I still don't get why you're saying I can't install it when I already have installed it and used it to play games just fine >_>

XBCD 0.2.7 Discussion

Posted: Mon Feb 25, 2013 9:55 pm
by Squall Leonhart
Completing the setup and the dpinst phase does not mean the driver is installed.

 


the setup phase just places the files and creates the necessary registry information for the supported controls, while the dpinst phase will complete regardless of whether the available control is supported or not.

 


in this case, dpinst just adds the driver to the windows driver store for whenever you finally connect a supported device.

XBCD 0.2.7 Discussion

Posted: Tue Feb 26, 2013 12:19 am
by Ashnal
It IS installed and it DOES work. The driver is functioning fine. The XBCD Controller shows up in the controllers panel and receives input ... it's the config app that isn't playing nice.

 


I'm not trying to be pushy ... I just get the feeling you aren't quite understanding me [img]<fileStore.core_Emoticons>/emoticons/sad.png[/img]/emoticons/sad@2x.png 2x" width="20" height="20" />

XBCD 0.2.7 Discussion

Posted: Tue Feb 26, 2013 12:45 am
by Squall Leonhart
just because the device name is XBCD Controller driver (changed by the setup script) doesn't mean the driver installed by dpinst is the one being utilised by the controller.

 


screenshot the Human interface devices section of device manager

XBCD 0.2.7 Discussion

Posted: Tue Feb 26, 2013 9:41 am
by Ashnal
Ah I see. There's two devices now, one which is a generic game controller, and another labeled XBCD. Both with the same ID.

 


This is kinda confusing to me I admit. The entry for the controller in the "Devices and Printers" control panel section references BOTH the virtual bus controller that I installed XBCD to, and the generic HID.

 


Why is it that I saw a change in the controller's behavior and button layout when I installed XBCD over the Microsoft drivers? I don't recall the generic device being present when I was using the microsoft drivers.