x360ce setup - for use with xbcd

Discussion and Development board for the popular XBOX(360) controller driver.


FatJoe
Junior Member
Posts: 9
Joined: Thu Sep 13, 2012 2:06 am

x360ce setup - for use with xbcd

Post by FatJoe »

Thx for the reply.

 


Here i activate the driver and disable the MS Driver:


Image

 


x360.exe and the dlls:


Image

 


Selecting a random profile:


Image


Unfortunately the profile 2F8C1B2D doesnt' exist anymore. Dunno if it woul work but i don't think so.

 


Trying to reconfigure manually:


Image

 


My problem is that it's grey and doesn't record my commands, just bleeps after every action. When i save and load the game, it's still the crippled unaltered profile thats working )-:


In this case, both analogue sticks don't work...
Last edited by FatJoe on Sat Sep 15, 2012 3:52 am, edited 1 time in total.

Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

x360ce setup - for use with xbcd

Post by Squall Leonhart »

looks like native is turned on, in the advanced tab.

FatJoe
Junior Member
Posts: 9
Joined: Thu Sep 13, 2012 2:06 am

x360ce setup - for use with xbcd

Post by FatJoe »

Do you mean pass through ?


Image

 


Checked it and unchecked it but can't say if it changed something as i loaded another conifg again before. It's the most used for dark souls, and it's still


crippled. Start is put on x only to begin with. Vibration doesn't work here but at least the sticks are fine.

 


Is there anyway to ungrey the controller and make it show my input commands, just as it does when it is run with the original MS Driver ?
Last edited by FatJoe on Sat Sep 15, 2012 11:12 pm, edited 1 time in total.

Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

x360ce setup - for use with xbcd

Post by Squall Leonhart »

delete the x360ce.ini and restart the setup app, the controller image should ungrey when native is unchecked.

FatJoe
Junior Member
Posts: 9
Joined: Thu Sep 13, 2012 2:06 am

x360ce setup - for use with xbcd

Post by FatJoe »

Okay that worked.

 


But new Problems ahead )-:

 


1. Start and back are swapped. Means i press back and start glows and vive versa. Rather minor problem.

 


2. The triggers arent't recognized at all. Every other button glows, they don't react at all.

 


3. Testing vibration and everything works fine, but ingame it's disabled...


Would be nice if you knew some more magic tricks D:

Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

x360ce setup - for use with xbcd

Post by Squall Leonhart »

thats because you have them set backwards in the xinput config app

 


start should be button 7 and back should be button 8

 


XBCD defaults to the triggers as digital buttons, the setup app can change these to be axis using the x360ce profile
Last edited by Squall Leonhart on Sun Sep 16, 2012 2:52 pm, edited 1 time in total.

FatJoe
Junior Member
Posts: 9
Joined: Thu Sep 13, 2012 2:06 am

x360ce setup - for use with xbcd

Post by FatJoe »

I think my real problem atm is that the controller sometimes randomly disconnects and messes up the calibration while in the x360ce tool. Has become worse over the time unfortunately.

 


Here it shows, that the trigger is half pressed for example even if it isnt.


Image

 


A new controller is on the way already. What i've been trying to do all the time btw is to put the left trigger on left stick click and B on the left trigger. Hope im finallly being able to finish when it arrives -.-

FatJoe
Junior Member
Posts: 9
Joined: Thu Sep 13, 2012 2:06 am

x360ce setup - for use with xbcd

Post by FatJoe »

So the new Controller arrived. Try to calibrate through joy.cpl but the sliders seem to jump around randomly when i calibrate manally. So i just resetted it to "standard calibration"

 


But the triggers still don't react in x360ce. Left is HAxis 3, right is IHAxis 3 which is also the standard on the MS Driver. But nothing happens:msn_wiltedrose:

wlfwood
Junior Member
Posts: 5
Joined: Mon Oct 01, 2012 4:05 pm

x360ce setup - for use with xbcd

Post by wlfwood »


So the new Controller arrived. Try to calibrate through joy.cpl but the sliders seem to jump around randomly when i calibrate manally. So i just resetted it to "standard calibration"

 


But the triggers still don't react in x360ce. Left is HAxis 3, right is IHAxis 3 which is also the standard on the MS Driver. But nothing happens:msn_wiltedrose:





 


I ran into a similar problem with the triggers with my generic Xbox Controller S. The first thing to do is, go into the Start Menu > Programs > XBCD and run "XBCD Setup Utility" make sure the preset "XBCD 360 Emu" is selected and Apply, then you can close that.

 


Next run joy.cpl and calibrate to fix the always on trigger buttons.

 


Run x360ce.exe again and see if the triggers respond with Iaxis 3 and 6 assigned.

 


Good Luck, I hope this helps.
Last edited by wlfwood on Tue Oct 02, 2012 7:12 am, edited 1 time in total.

Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

x360ce setup - for use with xbcd

Post by Squall Leonhart »

Run x360ce.exe again and see if the triggers respond with Iaxis 3 and 6 assigned. If they do, but still show as being pressed when they aren't, you'll need to adjust the Left or Right Trigger Dead Zone in the Advanced tab. Adjusting the Left Trigger Dead Zone to 51% fixed this issue for me.

 


No, adjusting the deadzone is not required and will just break the triggers range in games that use it for acceleration or shooters that differentiats between burst and automatic fire depending on the pressure

 




PS. I would open joy.cpl again and reset the calibration to default before doing ANY of the above, joy.cpl doesn't seem to be very good for calibrating these, the XBCD Setup Utility is infinity better.

 


Joy.cpl calibrates the triggers as expected, since each trigger is on the negative range of 2 different axes (-Z and -RZ) the calibration corrects the position of the center so that the undepressed position of the trigger counts as 0.

Locked