Lufia - The Ruins of Lore glitch

Post Reply
infiltrator
Junior Member
Posts: 9
Joined: Thu May 01, 2008 3:17 pm

Lufia - The Ruins of Lore glitch

Post by infiltrator »

Version : VBA-M SVN 781


Render : OpenGL

 


[attachment=125]


It had glitch on link button.

 


[attachment=126]


More glitch.

 


[attachment=127]


Little glitch on skill windows.
Hard Core Rikki
Member
Posts: 78
Joined: Tue Apr 08, 2008 5:26 am

Lufia - The Ruins of Lore glitch

Post by Hard Core Rikki »

Known since 58* revisions. Its not specific to OpenGL by the way, and shows only for texts, even without filters.


Thanks for reporting.
Last edited by Hard Core Rikki on Fri Nov 14, 2008 6:09 pm, edited 1 time in total.
spacy51
Senior Member
Posts: 371
Joined: Tue Mar 18, 2008 9:59 am

Lufia - The Ruins of Lore glitch

Post by spacy51 »

It exists in SVN451 as well.


It was even there before SVN368, whre jbo_85 optimized some stuff in the renderers.

 


I looked closely at the produced results, and for me it looks as if horizontal or vertical mirroring is not applied to tiles when transfered from char base to BG2 (mode0).


Moreover, it seems to occur randomly when switching from one game menu into another or back.

 


It's fine in VBA 1.7.2


It's fine in VBA 1.8.0 beta 2 (December 20 2004)


It's broken in VBA 1.8.0 beta 3 (October 1 2005)


-> broke between 1.8.0 beta 2 to 3
Last edited by spacy51 on Fri Nov 14, 2008 11:54 pm, edited 1 time in total.
spacy51
Senior Member
Posts: 371
Joined: Tue Mar 18, 2008 9:59 am

Lufia - The Ruins of Lore glitch

Post by spacy51 »

I just tryied it out, the issue was caused by one of the commits from June 25, 2005:


https://sourceforge.net/mailarchive/forum.php?forum_name=vba-commit&max_rows=100&style=threaded&viewmonth=200506

 

 


EDIT: Unfortunately, I can't find the error myself.


I'll attach two versions of the VBA CVS source code:


- VBA_good.7z: the last version without the issues mentioned above


- VBA_bad.7z: one day later, where the issues first appeared.

 


I also attached a patch file from good to bad.

 


Compare both source trees with WinMerge or a similar tool and please post if you found the issue.
Last edited by spacy51 on Sat Nov 15, 2008 5:47 am, edited 1 time in total.
Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

Lufia - The Ruins of Lore glitch

Post by Squall Leonhart »

Spacy, try enabling Mirroring in the game overrides menu.
spacy51
Senior Member
Posts: 371
Joined: Tue Mar 18, 2008 9:59 am

Lufia - The Ruins of Lore glitch

Post by spacy51 »

Does not help.

 


[Please have a look at my editoed post above: http://vba-m.com/forum/lufia-the-ruins-of-lore-glitch-t-301.html#pid2620 ]
Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

Lufia - The Ruins of Lore glitch

Post by Squall Leonhart »

Check GBA.cpp Line 155 and lower. heavy changers were made to OBJTiles and some stuff probably GBA GFX related.
Last edited by Squall Leonhart on Sat Nov 15, 2008 6:10 am, edited 1 time in total.
Squall Leonhart
Posting Freak
Posts: 1217
Joined: Tue Mar 18, 2008 2:21 am

Lufia - The Ruins of Lore glitch

Post by Squall Leonhart »

The problem does not occur when Bilinear is disabled.

 


OK, it does, but i had it working without the problem a second ago.
Last edited by Squall Leonhart on Sat Nov 15, 2008 6:20 am, edited 1 time in total.
spacy51
Senior Member
Posts: 371
Joined: Tue Mar 18, 2008 9:59 am

Lufia - The Ruins of Lore glitch

Post by spacy51 »

As I said, the issues occur random, so I reommend switching between the main menu & the continue menu several times to make sure no issues occur. It would be great if somone could show this thread to people like chrono wo seem to be up to the task.
Last edited by spacy51 on Mon Nov 17, 2008 8:46 am, edited 1 time in total.
Normmatt
Junior Member
Posts: 1
Joined: Sun Feb 10, 2013 5:50 am

Lufia - The Ruins of Lore glitch

Post by Normmatt »

This issue has been fixed in revision 1191. The cause was cpuDmaHack on unmapped reads.
Post Reply